Pistol Smith Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello all,

I thought it would be easy for me to swap out the mainspring housing on my Kimber stainless II (full size) with a S&A mag guide. Everything seemed to go well. Pins punched out easily enough. Didn’t hit myself with the mainspring. Put the mainspring in the S&A housing and put it on my pistol. To my dismay the hammer will not cock and the hammer follows the slide when racked. Ugh! Put the original mainspring housing back on (with mainspring) and the hammer still won’t cock.

I should have stopped there but didn’t. Just being dumb I guess. I began to disassemble it further to see if I could find out what was going on (eg. Sear spring out of place). Not only could I not figure it out, I can’t get the safety lock back on. I was planning on sending it to someone like Dane after the New Year when my cash flow improves. Now it looks like I will have to send it sooner. However, I would like to get the pistol back together and functional; I think I am just missing some trick or such. Any help is appreciated. Thanks.

Dan
 

· Registered
Joined
·
1,355 Posts

· Registered
Joined
·
1,393 Posts
Hey Dan,

As mentioned "over there" check your left hand leaf of the sear spring. Make sure it's on TOP of the sear.

Your thumb safety will only go in if the hammer is cocked, and you position the safety about halfway between on and off - then push it straight in.

Gyp_c has provided some useful links above. They should help you with the details! :smile:
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Thanks all. Got it sorted out last night; left leaf of sear spring was the key to it all. Once in place the safety lock went in easily, the hammer cocks, and the safeties all work. However, I will take it to the range before I carry it again.

Cheers,

Dan
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top